FileMaker 19

Filemaker 19 was released a few months ago. If you are thinking of upgrading and are a Macintosh user please be aware that only Mac OS 10.14 and higher are supported, so please check your computer can support these operating systems before you upgrade. If you upgrade your OS please be aware that some of your other software may also need to be upgraded as well.

Leave a Reply

Your email address will not be published. Required fields are marked *